I am trying to create a JDBC data source in WebSphere. Testing the connection returns the error message:

JVMCFRE003 bad major version; class=com/microsoft/sqlserver/jdbc/SQLServerConnectionPoolDataSource, offset=6

my environment and configuration:

WebSphere 8.5.5.13
JDK 1.7_64
JDBC driver: sqljdbc41.jar
OS: Linux eagnmnmed294 3.0.101-108.68-default #1 SMP Mon Aug 13 18:53:23 UTC 2018 (ef94234) x86_64 x86_64 x86_64 GNU/Linux

SystemOut.log starts with:

************ Start Display Current Environment ************ WebSphere Platform 8.5.5.13 [ND 8.5.5.13 cf131801.05] [IBMJAVA7 7.0.10.15 cf131751.02] [IBMJAVA8 8.0.5.6 cf131751.02] running wi th process name eagnmnmed294Network\eagnmnmed294\ploc_sit_294 and process id 47449 Host Operating System is Linux, version 3.0.101-108.68-default Java version = 1.7.0, Java Runtime Version = pxa6470sr10fp20-20180221_01 (SR10 FP20), Java Compiler = j9jit26, Java VM name = IB M J9 VM was.install.root = /opt/WebSphere/AppServer855 user.install.root = /opt/WebSphere/AppServer855/profiles/eagnmnmed294 Java Home = /opt/WebSphere/AppServer855/java_1.7_64/jre

I have also tried with another version of driver: sqljdbc42.jar

I got the same error.

What I am missing here?

Appreciate your help!

The sqljdbc42.jar corresponds to JDBC 4.2, which is a Java SE 8 specification and is compiled with Java 8 bytecode.

Since you are running on Java 7, you can't run higher than Java 7 bytecode. Try downgrading to a JDBC 4.1 jar that is compiled with Java 7 bytecode instead, or upgrade your Java runtime to be Java 8.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.